Bad naming of category "Chord"/"Note" in the Inspector

• Feb 19, 2021 - 14:21
Ergonomical (UX)
S5 - Suggestion

If one wants to make a note smaller, the intuitive thing to do would be to click on "Small" under "Note" in the Inspector. That, however only affects the notehead; if one wants the entire note to be smaller, one has to click on "small" under the "Chord" heading. This is all fairly unintuitive.
Likewise, coloring, hiding and selecting in most cases only applies to the notehead, not the entire note.


Severity S4 - Minor S5 - Suggestion

That is indeed by design, and a note, in MuseScore, has nothing but the pitch (and a head), it is the chord that has the duration (and stem), even a single note is really a chord
Not sure whether we can come up with a better naming.

In reply to by Jojo-Schmitz

I've understood that it is by design, and there are probably good reasons for it, but in the rest of the world a note is the whole sign, and a chord is a group of notes played at the same time. A first step would be to name the "Note" category "Notehead" instead, and possibly change "Chord" to "Note/Chord symbol". That would make it much clearer, since it does not go against ordinary language.

Reported version 3.6  

Well, no, a notehaed has just a shape, no pitch. and a Chord is very different from a Chord Symbol.
Aynway, the whole UI, including the Inspector, will be getting a major overhaul for MuseScore 4

True, the compound "Note/Chord symbol" turned out very wrong. But again: in the real world, a notehead is just the round part of a note, which contains everything else as well.
Now, looking at the entire Inspector layout when a single notehead is selected, it seems that what I refer to as the "Note" (or "Note/Chord symbol") is covered more or less by the "Segment" header, only - no, since segment covers everything in all the other instruments as well - but: If I wanted to color or hide or make small an entire eight-note, I would not be looking under "Chord" to do it.
The names of these headings do seem quite programmer oriented: Element, Segment, Chord, Note... Sure, they can be defined that way, and internally I'm sure it makes sense, but to a musician...?
Anyway, it's really the Chord/Note distinction that bugs me. It would help a lot if the "Play" items under "Note" were put under a separate heading: "Tone" (since notes are what you see, tones what you hear). Then "Note" could become "Note symbol" and also include settings for flag and stem.
Just a suggestion. But I'll await 4.0. Looking forward to it!

In reply to by Jojo-Schmitz

Well, as I see it, the pitch isn't really set in the inspector, but by the position in the staves (plus possible accidental). Neither are the dynamics of the tone, which are also set by assigning certain properties in the score (or by default). Both are not changed basically by merely altering values in the inspector. Only relative aberrations from the standard settings are stored with the inspector. So I'd vote for renaming that section that now is called "note" into "notehead".
I see your point, that the values of "replay", pitch", "attack dynamics" and "attack" can be set in the note section, too. These are the relative aberrations. But, if the inspector is already segmented into individual "element", "segment", "chord", "note", why not introduce a further segment "pitch" (or "replay" if you rather will) above the "replay"-checkbox? Then the segment "note" can be renamed into "notehead" without becoming unprecise. This would not even affect the way the values are stored. It would be a mere UI design feature eliminating communication irritations between program and user. Moreover, Musescore even now assigns further elements of the ordinary note to several buttons "stem", "beam" etc.
As you announce a thorough facelift for the UI (and inspector), you may find completely different solutions, but the raised issue, that the notehead is only part of a group of elements, which as a whole represent, what commonly is considered "note", should be met. That is, Values like "pitch", attack" or "replay/silent" mode should not be part of the "notehead".
If you argue, that a note consists of several elements, I agree instantly and completely. But then the "pitch" etc. constitute an element of its own and a label "note" is not helpful any longer, for it denotes the wholeness of the elements. It's almost wrong ... That's the core of the irritation, I guess. Hopefully, this consideration leaves its mark on the new design.